Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
User ID:
Password:
  Register

水平不够,,,,w了特别久

Posted by leiyongZL at 2016-07-25 16:14:48 on Problem 2406
/******


Submit

Status







































































Description


Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).


Input


Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.


Output


For each s you should print the largest n such that s = a^n for some string a.


Sample Input

abcd
aaaa
ababab
.



Sample Output

1
4
3



Hint


This problem has huge input, use scanf instead of cin to avoid time limit exceed.

+
********/
#include <iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int next[10000005];
void getnext(char *S,int& R)
{
    int j=0;
    next[0]=0;
    for(int i=1; S[i]!='\0'; i++)
    {

        while(j>0&&S[i]!=S[j])
        {
            j=next[j-1];
        }
        if(S[i]==S[j])
        {
            j++;
        }
        next[i]=j;
    }
}
int main()
{
    char S[1000005];
    while(scanf("%s",S)&&S[0]!='.')
    {
        memset(next,0,sizeof(next));
        int R=0;
        getnext(S,R);
        int l=strlen(S);
        int j=next[l-1];
        int m=l-j,k=j,B;
        while(j>0)
        {
            if(j==m)
            {
                B=1;
                break;
            }
            j=next[j-1];
            int n=k-j;
            if(n!=m)
            {
                B=0;
                break;
            }
            k=j;
        }
        //cout<<m<<endl;
        if(B)
            cout<<l/(m)<<endl;
        else
            cout<<"1"<<endl;
    }
    return 0;
}

Followed by:

Post your reply here:
User ID:
Password:
Title:

Content:

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator