Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
User ID:
Password:
  Register

SPFA 360ms,ASK FOR 0ms Solution

Posted by snowflysky at 2009-08-03 09:05:54 on Problem 3268
/*
Silver Cow Party
Time Limit: 2000MS  Memory Limit: 65536K 
Total Submissions: 3321  Accepted: 1407 

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). 
A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; 
road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. 
Each cow is lazy and thus picks an optimal route with the shortest time. 
A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. 
The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output

Line 1: One integer: the maximum of time any one cow must walk.
Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output

10
Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
Source

USACO 2007 February Silver
*/
#define MAXN 1000
#include<iostream>
#include<memory.h>
using namespace std;
class edge{
	public:
		int to;
	    int cost;
		edge *next;
		edge(int _to,int _cost,edge *_next):to(_to),cost(_cost),next(_next){}
} *hLink[MAXN+1];
int n,m,x;
int mincost[MAXN+1],cost[MAXN+1];
int Queue[MAXN*MAXN],qH,qT;
bool inQueue[MAXN+1];
void spfa(int s){
	memset(inQueue,false,sizeof(inQueue));
	for (int i=1;i<=n;++i) cost[i]=0x7fff;
	cost[s]=0;inQueue[s]=true;
	Queue[qH=0]=s;qT=1;
	while (qH!=qT){
		int cur=Queue[qH++];qH%=MAXN*MAXN;
		inQueue[cur]=false;
		for (edge *p=hLink[cur];p;p=p->next)
			if (cost[p->to]>cost[cur]+p->cost){
			   cost[p->to]=cost[cur]+p->cost;
			   if (!inQueue[p->to]){
				   inQueue[p->to]=true;
				   Queue[qT++]=p->to;
				   qT%=MAXN*MAXN;
			   }
			}
	}
}
int main (void){
	int a,b,c;
	cin>>n>>m>>x;
	for (int i=0;i<m;++i){
		cin>>a>>b>>c;
		hLink[a]=new edge(b,c,hLink[a]);
	}
	for (int i=1;i<=n;++i){
		spfa(i);
		if (i!=x) mincost[i]+=cost[x];
		else{
			for (int j=1;j<=n;++j)
				if (j!=x) mincost[j]+=cost[j];
		}
	}
	int maximum=0;
	for (int i=1;i<=n;++i)
		if (i!=x) maximum=max(maximum,mincost[i]);
	cout<<maximum<<endl;
	return 0;
}

Followed by:

Post your reply here:
User ID:
Password:
Title:

Content:

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator