Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
User ID:
Password:
  Register
Language:
a加b
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 573944Accepted: 323268

Description

计算a加b。

Input

两个整数a和b,其中0≤a, b≤10。

Output

输出a与b的和。

Sample Input

1 2

Sample Output

3

Hint

问:怎样输入输出?
答:你的程序应该从标准输入(stdin)中读取数据,而将结果写到标准输出(stdout)。比如,在C语言中你可以使用“scanf”,在C++语言中则可以使用“cin”来输入;输出可以使用C语言的“printf”或者C++语言的“cout”。其他的语言可以参照下面的程序。

注意:不要向标准输出写入题目要求输出结果之外的其他数据,否则你会被判为“Wrong Answer”,即错误的运行结果。

你的程序也不能试图读或写任何文件,否则你可能被判为“Runtime Error”(运行时错误)或“Wrong Answer”(错误结果)。

下面是这道题的一个C++或者G++的程序。
#include <iostream>
using namespace std;
int main()
{
int a,b;
cin >> a >> b;
cout << a+b << endl;
return 0;
}

注意:对于GCC或者G++,main()函数的返回值必须是int型,否则可能导致“Compile Error”即编译错误。

下面是这道题的一个C或者GCC的程序。
#include <stdio.h>

int main()
{
int a,b;
scanf("%d %d",&a, &b);
printf("%d\n",a+b);
return 0;
}
下面是这道题的一个Pascal程序。
program p1000(Input,Output);
var
a,b:Integer;
begin
Readln(a,b);
Writeln(a+b);
end.
下面是这道题的一个Java程序,这里Java编译器采用的是JDK 1.5。
import java.io.*;
import java.util.*;
public class Main
{
public static void main(String args[]) throws Exception
{
Scanner cin=new Scanner(System.in);
int a=cin.nextInt(),b=cin.nextInt();
System.out.println(a+b);
}
}
而老版本的JDK 1.4程序如下:
import java.io.*;
import java.util.*;

public class Main
{
public static void main (String args[]) throws Exception
{
BufferedReader stdin =
new BufferedReader(
new InputStreamReader(System.in));

String line = stdin.readLine();
StringTokenizer st = new StringTokenizer(line);
int a = Integer.parseInt(st.nextToken());
int b = Integer.parseInt(st.nextToken());
System.out.println(a+b);
}
}
下面是这道题的一个Fortran程序。
	PROGRAM P1000
IMPLICIT NONE
INTEGER :: A, B
READ(*,*) A, B
WRITE(*, "(I0)") A + B
END PROGRAM P1000

Source

Translator

Xie Di, xiedi@POJ

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator